Radio Buttons

Issues related to forms.
Post Reply
terencewright
Posts: 11
Joined: Sun Feb 15, 2015 4:53 pm

Radio Buttons

Post by terencewright » Sat Dec 26, 2015 11:54 am

Hi

I seem to be having an issue with radio buttons! When I preview my page everything is as expected, radio buttons can be clicked and the page shows the selection, however when I publish my page and view it on my web server (Apache2), the radio buttons can be clicked but the page does not reflect the selection, it remains with the default radio button!

Can any one please advise.

Thanks
Terry

User avatar
Pablo
Site Admin
Posts: 2637
Joined: Mon Feb 13, 2006 7:00 am
Location: Europe
Contact:

Re: Radio Buttons

Post by Pablo » Sat Dec 26, 2015 12:28 pm

What exactly did you do?
What is the URL?
What is suppose to happen?

terencewright
Posts: 11
Joined: Sun Feb 15, 2015 4:53 pm

Re: Radio Buttons

Post by terencewright » Sat Dec 26, 2015 1:05 pm

I have a form which has 2 sets of radio buttons which control, via a web socket, parameters used to control a photographic application running on a raspberry pi. The raspberry pi is also running an apache2 web server serving my application web page.

Each radio button set has a unique name, and each button has a specific value. I have an on_click() function attached to each radio button.

When a radio button is clicked it send a message via a web socket call to the application on my raspberry pi.

In my development the application returns a message, via the web socket, indicating the message received, this operates as expected i.e. I get the expected message back.

However when I click a radio button, I expect it to be selected and the previously selected radio button to be deselected, this does not happen for some reason. When I preview my page in QuickandEasy the radio buttons operate as expected.

User avatar
Pablo
Site Admin
Posts: 2637
Joined: Mon Feb 13, 2006 7:00 am
Location: Europe
Contact:

Re: Radio Buttons

Post by Pablo » Sat Dec 26, 2015 6:28 pm

Maybe this is helpful?
viewtopic.php?f=10&t=37833

terencewright
Posts: 11
Joined: Sun Feb 15, 2015 4:53 pm

Re: Radio Buttons

Post by terencewright » Sun Dec 27, 2015 10:59 am

Many thanks...

That solved the problem.

Great support.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest