Form not sending email or going to success page

Issues related to forms.
Post Reply
kgnoble
Posts: 24
Joined: Sun Jan 14, 2018 4:05 pm

Form not sending email or going to success page

Post by kgnoble » Sat Jun 02, 2018 11:44 am

Hi

I hope you can help to save what little hair I have left.

www.cageyenne.co.uk/evemusic

Any attempt at adding forms has not worked. I have changed the Contact_Us page to php. and there are no residual .html pages on the server.
I have checked with my web service supplier and they provide php; and in any case I have had a much earlier version actually working and responding with messages.
Do I need to change the index.html file to php? Or is it only the contact page that needs php

I should say I love the program but getting up to speed is hard work :-)

Keith

User avatar
Pablo
Site Admin
Posts: 2831
Joined: Mon Feb 13, 2006 7:00 am
Location: Europe
Contact:

Re: Form not sending email or going to success page

Post by Pablo » Sat Jun 02, 2018 1:18 pm

The form seems to be ok.
If the email is not sent then this is usually a server configuration issue.

See also the FAQ:
http://www.quickandeasywebbuilder.com/f ... 10&t=32967
(Emails are not arriving in my inbox..)

kgnoble
Posts: 24
Joined: Sun Jan 14, 2018 4:05 pm

Re: Form not sending email or going to success page

Post by kgnoble » Sat Jun 02, 2018 4:04 pm

Hi Pablo

Thanks for your response. I have tried a test single page response form and that has worked!

I assume something must be getting in the way preventing the response from a larger website.

Any ideas?

Regards

Keith

User avatar
Pablo
Site Admin
Posts: 2831
Joined: Mon Feb 13, 2006 7:00 am
Location: Europe
Contact:

Re: Form not sending email or going to success page

Post by Pablo » Sat Jun 02, 2018 5:06 pm

The size of the website does not matter.
If the email is not sent there this is most likely an issue on the server side.
For example, the server may be blocking certain email addresses.
Only your webhost can tell why the emails was not sent.
The script in the software does not have any restrictions.

kgnoble
Posts: 24
Joined: Sun Jan 14, 2018 4:05 pm

Re: Form not sending email or going to success page

Post by kgnoble » Sat Jun 02, 2018 6:22 pm

OK - thank you.

I am rebuilding the site around a known functioning response form and will check at which stage, if any, it goes wrong.

Slightly off topic, but relevant to me, is there anyway in which the object details can be saved and printed to make life easier when rebuilding the site?

Keith

User avatar
Pablo
Site Admin
Posts: 2831
Joined: Mon Feb 13, 2006 7:00 am
Location: Europe
Contact:

Re: Form not sending email or going to success page

Post by Pablo » Sat Jun 02, 2018 8:50 pm

I don't think you will need to rebuild your website.
If emails are not sent, then this is usually (99%) a issue of the server. Rebuilding your website will not change that.

You can copy/paste objects, or you can save them as 'blocks' to reuse them later.
http://quickandeasywebbuilder.com/blocks.html

BTW: did you sent me a PayPal donation?

kgnoble
Posts: 24
Joined: Sun Jan 14, 2018 4:05 pm

Re: Form not sending email or going to success page

Post by kgnoble » Sat Jun 02, 2018 10:46 pm

Welllllll....

I am rebuilding the site page by page, testing the contacts form at each stage, and so far it is working - the old site contact form is still not! I will keep you posted.

Keith

(Yes I did make a donation)

User avatar
Pablo
Site Admin
Posts: 2831
Joined: Mon Feb 13, 2006 7:00 am
Location: Europe
Contact:

Re: Form not sending email or going to success page

Post by Pablo » Sun Jun 03, 2018 7:19 am

and so far it is working
Ok, great!
Yes I did make a donation
Thank you very much!

kgnoble
Posts: 24
Joined: Sun Jan 14, 2018 4:05 pm

Re: Form not sending email or going to success page

Post by kgnoble » Sun Jun 03, 2018 5:23 pm

HI Pablo

I don't know what your view will be on this, but by reversing the development of the site, I have got to the point where the response form works, seemingly consistently. It started working when I removed a layer which had sat under the form. With that out of the way. .so far seems so good.

I would be interested in your views - you may say why did I have a layer? - to which I would answer I don't know except it seemed appropriate at the time:-)

Let me know if you have any comments. The working site (a little untidy) is now at www.cageyenne/evemusictest/index.php

Best

Keith

kgnoble
Posts: 24
Joined: Sun Jan 14, 2018 4:05 pm

Re: Form not sending email or going to success page

Post by kgnoble » Sun Jun 03, 2018 6:08 pm

sorry - of course it should be www.cageyenne.co.uk/evemusictest/index.php

K

User avatar
Pablo
Site Admin
Posts: 2831
Joined: Mon Feb 13, 2006 7:00 am
Location: Europe
Contact:

Re: Form not sending email or going to success page

Post by Pablo » Sun Jun 03, 2018 8:23 pm

Maybe you have accidentally nested the form and layer? Nested forms are not supported in HTML.

betwixt
Posts: 24
Joined: Mon Nov 25, 2013 3:49 pm

Re: Form not sending email or going to success page

Post by betwixt » Sun Jun 03, 2018 9:17 pm

Keith, you really need to scale the images!

The two photographs are over 5Mb each and took over 1 minute to completely show on my admittedly poor broadband connection.

Brian.

kgnoble
Posts: 24
Joined: Sun Jan 14, 2018 4:05 pm

Re: Form not sending email or going to success page

Post by kgnoble » Mon Jun 04, 2018 10:54 am

Ouch - thank you! Just got my superfast fibre which obviously seems to be working :-)

Will go back and sort that out

Regards

Keith

kgnoble
Posts: 24
Joined: Sun Jan 14, 2018 4:05 pm

Re: Form not sending email or going to success page

Post by kgnoble » Mon Jun 04, 2018 12:11 pm

....done

K

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests