Slideshow not moving

All Quick 'n Easy Web Builder support issues that are not covered in the forums below.
alex4orly
Posts: 183
Joined: Thu Jul 23, 2020 9:34 am

Slideshow not moving

Post by alex4orly »

This was working for many years, but no longer moves. Please ignore the text - the problem is the slide show

http://squadron-125.org.il/mypdf/20090411.html
http://squadron-125.org.il/mypdf/20161209.html

But this one, is working :
http://squadron-125.org.il/mypdf/20171211.html

Any suggestions?

Thanks
User avatar
Pablo
Site Admin
Posts: 3386
Joined: Mon Feb 13, 2006 7:00 am
Location: Europe
Contact:

Re: Slideshow not moving

Post by Pablo »

For me, they all do not work.

Did you make any recent changes?
Did you publish all files?
Do you have a demo project so I can see all your settings?
alex4orly
Posts: 183
Joined: Thu Jul 23, 2020 9:34 am

Re: Slideshow not moving

Post by alex4orly »

Sorry, the one that works is here :
http://squadron-125.org.il/mypdf/20191127.html

The first image is the slideshow - just wait a bit for it to start

Unfortunately, this project is from my "Windows" days of wwb and I don't have it now in Linux
I am trying to find what is it and fix the html page by direct editing, if I can.

Thanks
User avatar
Pablo
Site Admin
Posts: 3386
Joined: Mon Feb 13, 2006 7:00 am
Location: Europe
Contact:

Re: Slideshow not moving

Post by Pablo »

The main difference is that this page is using valid filenames.
The other pages do not comply to the naming rules.

See this related FAQ:
https://www.quickandeasywebbuilder.com/ ... f=10&t=131
alex4orly
Posts: 183
Joined: Thu Jul 23, 2020 9:34 am

Re: Slideshow not moving

Post by alex4orly »

Well, I changed the file names, and the html - but no go

https://squadron-125.org.il/mypdf/20171211.html

Now there is a js error

Hope you can figure it out

Thanks
User avatar
Pablo
Site Admin
Posts: 3386
Joined: Mon Feb 13, 2006 7:00 am
Location: Europe
Contact:

Re: Slideshow not moving

Post by Pablo »

It looks like one of the required script files is missing (utils.min.js)
Can you create a demo project, so I can see all your settings?
alex4orly
Posts: 183
Joined: Thu Jul 23, 2020 9:34 am

Re: Slideshow not moving

Post by alex4orly »

I had this problem in the past, the only way was to recreate the page from scratch - so, creating a sample project will do nothing - the page will work.
Where is the missing script? Is it not part of wwb?

Cheers
User avatar
Pablo
Site Admin
Posts: 3386
Joined: Mon Feb 13, 2006 7:00 am
Location: Europe
Contact:

Re: Slideshow not moving

Post by Pablo »

The script is part of the software and it should be included automatically.

Are you using the latest version? Because it looks like an older version of the carousel is included.

Or maybe you have published the pages with different versions?
alex4orly
Posts: 183
Joined: Thu Jul 23, 2020 9:34 am

Re: Slideshow not moving

Post by alex4orly »

This project is old, I have no valid backup of it, yes, it was created with an older version of WB under Windows
So, what can I do now? where can I find that script? If the script is / was part of web at that version, why is it NOT there?

That file is there : squadron-125.org.il/mypdf/util.min.js
In the same folder with the html page, why did you think it is not there?

Thanks
User avatar
Pablo
Site Admin
Posts: 3386
Joined: Mon Feb 13, 2006 7:00 am
Location: Europe
Contact:

Re: Slideshow not moving

Post by Pablo »

There seems to be a mix up of your files on the server.
The carousel script is from a newer version. But the HTML file was generated with an older version.

You will either need to republish all files with the new version or republish all files with the old version.
alex4orly
Posts: 183
Joined: Thu Jul 23, 2020 9:34 am

Re: Slideshow not moving

Post by alex4orly »

Yes, I did publish the new site into the same folder as the old website was.
Seeing that I no longer have the old project, it sounds I will have to remake each page from scratch

Thanks
User avatar
Pablo
Site Admin
Posts: 3386
Joined: Mon Feb 13, 2006 7:00 am
Location: Europe
Contact:

Re: Slideshow not moving

Post by Pablo »

Alternatively, you can modify the code of the (old) pages manually.

Replace

Code: Select all

<script src="transition.min.js"></script>
<script src="carousel.min.js"></script>
with

Code: Select all

<script src="util.min.js"></script>
<script src="carousel.min.js"></script>
alex4orly
Posts: 183
Joined: Thu Jul 23, 2020 9:34 am

Re: Slideshow not moving

Post by alex4orly »

Based on this, I only need to change the top line in the example, the 2nd line is the same
Or?

I replaced the lines as suggested, but the problem is still there (I made the change on my local machine, didn't publish it to the site

Looking forward to your instructions

Thanks again
User avatar
Pablo
Site Admin
Posts: 3386
Joined: Mon Feb 13, 2006 7:00 am
Location: Europe
Contact:

Re: Slideshow not moving

Post by Pablo »

You will need to edit the online HTML.

The reason why you have this problem me is becuase you have a mix of old and new files on the server.
The carousel.min.js on the server is from a newer version, but the HTML is still referring to the old code.

The file 'util.min.js' is already on the server so that is why I think my solution will work.

https://squadron-125.org.il/mypdf/util.min.js
alex4orly
Posts: 183
Joined: Thu Jul 23, 2020 9:34 am

Re: Slideshow not moving

Post by alex4orly »

I understand, just asking again
It seems I need to change the first line only.
Am I correct?

Cheers
Post Reply